Tutorial Project

This tutorial explains how to create a project that other tutorials will use. Further all tutorials assume you are working with this project.

Note

In case you find something described in this tutorial unfamiliar, see section Introduction for general information on pSeven interface and functions.

Creating a Project

Every workflow in pSeven is a part of some project. A project can contain multiple workflows and provides a database to store workflow results. Projects are also used to organize files — for example, keeping related workflows and their input data together.

From the technical point of view, a project is just a directory containing a few special files that allow pSeven to recognize this directory as a project. Aside from that, there are no real restrictions on project contents: the project directory can contain any number of workflows and reports, data files, executables and so on. There is no special import function for additional files — you can simply open the project directory and copy the files into it.

When you create a project, you only need to select its name and location. In general, new projects can be located anywhere, but for a tutorial it is recommended to create a project in the default workspace directory.

  • Click b_home button 1 to open the default workspace directory in the Filesystem pane.

To verify, see if the directory named Examples-6.11 exists there — it contains example projects which are automatically created by pSeven in the default workspace directory.

../_images/page_tutorials_project_01.png
  • Click the Create project button 2 to start a project. This button opens the Create Project dialog 3. You can also select File ‣ Create Project from the main menu.
  • Input your project name (Tutorials) in the dialog, and leave the location default.
  • Click b_create.

After you click b_create in the Create Project dialog, the new project opens automatically. New projects have a default description 1 explaining how to edit the contents of the Project Description tab.

Project description uses CommonMark syntax. You can also add formulas to the Project or Workflow descriptions using \(KaTeX\) markup. Formulas are represented within the display math environment \($$...$$\). The list of other supported functions can be found here.

../_images/page_tutorials_project_02.png

A new project contains the main project file (project.p7prj) and two files you can edit — the project description (README.md) and thumbnail (README.png).

The system files are shown only in the Filesystem pane 2 and must not be edited. The Project pane 3 shows only the files that can be edited in pSeven — such as the project description, workflows, reports and data files.

Since pSeven project is a directory, there is no save function for it as such. You can safely close the project after editing it; if pSeven detects unsaved changes in workflows or reports, you will be informed about it with a save dialog.

  • Try closing the project (File ‣ Close Project menu).
../_images/page_tutorials_project_03.png

After closing the project, pSeven switches back to the Welcome tab (while a project is open, you can also switch between Welcome and Project Description manually). Note that your project is added to the recent list 1 and file attributes (type, size and modification date) are now shown in the tooltip 2 when you select the main project file or the project directory.

  • Re-open the project from the recent list or by double-clicking the main project file 3 in the Filesystem pane.

Adding Files

Further tutorials will require some resource files to test the workflows you create. You can copy these files from Examples-6.11 directory: it already contains some data samples and a simple program which will be used later in the Integration Basics tutorial. This is recommended in order to follow the tutorials exactly as they are documented.

../_images/page_tutorials_project_04_add_files_copypaste.png
  • Click b_home on the Filesystem pane toolbar to return to the default workspace directory.
  • Open the Examples-6.11 directory.
  • Double-click the prj2.03 General - Integration project to show its contents. This opens the project directory but does not load the project.

Now you can copy files and directories from Filesystem to Project.

  • In the Filesystem pane, select 1 two directories: templates and tools (hold Ctrl or Shift for multiselection).
  • Select Copy from the context menu b_context in the Filesystem pane 2. Selected directories are copied to pSeven clipboard.
  • Select Paste from the context menu b_context in the Project pane 3.

Then repeat above steps for the samples directory in the prj2.01 General - Sample-Based Approximation project

Verify the prjTutorials project contents.

Root folder:

../_images/page_tutorials_project_05_project_files.png

samples folder:

../_images/page_tutorials_project_06_samples.png

templates folder:

../_images/page_tutorials_project_07_templates.png

tools folder:

../_images/page_tutorials_project_08_tools.png

Conclusion

Once you have a project ready, you can start making tutorial workflows. Note that it is strongly recommended to complete the following tutorials first:

  1. Simple Workflow: basic workflow editing.
  2. Workflow as a Tool: additional workflow configuration capabilities.
  3. Results and Reports: post-processing workflow results.

These tutorials provide a general practical introduction to pSeven and explain common functions which are not detailed in other tutorials.