Introduction

This page is a brief tour through pSeven and its graphical user interface.

Using Help

The Help menu in pSeven provides quick access to various parts of the documentation:

  • Help ‣ User Manual opens the starting page of this manual. To navigate the contents you can use the navigation bar on the left.
  • Help ‣ Examples opens the Examples page which explains how to run the examples included with pSeven installation.
  • Help ‣ Tutorials opens the Tutorials chapter which explains how to start working with pSeven.
  • Help ‣ FAQ opens the FAQ page, frequently asked questions and answers.

You can also find help shortcuts on the pSeven starting screen.

An online version of this manual is available at https://www.datadvance.net/permalink/en/pseven-platform-manual.

Starting pSeven

By default the pSeven installer creates a shortcut to pSeven on your desktop.

_images/page_introduction_01_desktop_sc.png

This shortcut is also added to the system menu upon installation.

  • In Windows: Start ‣ All Programs ‣ pSeven ‣ pSeven. You can also click Start and type pseven to search for the shortcut.
  • In Linux the location of shortcuts depends on your desktop environment. For example, in Ubuntu GNOME see Dashboard ‣ Applications, or search for pseven in Dashboard; in KDE, see All Applications ‣ pSeven.

Note

If your system is protected by a firewall, you may be required to allow connection to the pSeven license server on the first launch. See FAQ: Can pSeven be blocked by antiviruses or firewalls? for information on why this is required and other details.

For more details on pSeven shortcuts and other changes to system made by the installer, you can also see the Installation page.

When you launch pSeven for the first time, it installs examples in the workspace directory (see Examples). The workspace is a directory named pSeven located inside your documents directory. You can find the exact path to it after launching pSeven — see the Filesystem pane in Workspace.

See also

pSeven Runner
Special version of the pSeven environment that is intended to run existing workflows and does not require a full pSeven license.

General Interface

pSeven uses separate screens for different tasks such as managing projects and files, editing workflows, running them and post-processing workflow results:

  • Workspace, where you can manage projects and their contents — add workflows, data files and such. This screen opens by default when you start pSeven.
  • Edit, where you can create and configure workflows. This screen is available only after you open a project.
  • Run, where you can review workflows, make quick changes to their settings, run them and see main results. Like Edit, Run is available only after you open a project.
  • Analyze, where you can study detailed information obtained from workflow runs and post-process these results. This screen is also available only after opening a project.

Certain actions automatically switch the screen view. For example, selecting File ‣ New Workflow switches to Edit, and selecting File ‣ New Report switches to Analyze.

_images/page_introduction_02_iface.png

Each screen has its own layout detailed further. Common interface elements available on all screens are gathered in the left sidebar:

  • The main menu 1 provides access to general commands.
  • The screen selector 2 switches between screens.
  • The Issues button 3 toggles the eponymous Issues pane which shows validation warnings and errors. Its functionality depends on the selected screen — for example, in Edit pSeven validates block and link configuration, while in Analyze it can inform you about missing data, errors in plots, and so on.
  • The Console button 4 toggles the built-in pSeven console which shows detailed logs and can also be used as an interactive command-line interface.

Note also that many toolbars in pSeven provide a context menu b_context. This menu always contains a full set of commands, including those that are used less frequently than the commands directly available from the toolbar.

Workspace

The Workspace screen opens by default when you start pSeven.

_images/page_introduction_03_ws.png

This screen contains:

  • The Filesystem pane 1 — a simple file browser.
  • The Project pane 2 — shows contents of the current project.
  • The Welcome tab 3 — contains the shorcuts for starting work with pSeven.
  • The Project description tab 4 — active if the project is opened, shows its description.
  • Create project, workflow, report shortcuts 5.
  • Open project shortcut 6 and the list of recent projects 7.
  • Shortcuts to pSeven documentation and guides 8.
  • pSeven examples shortcut 9.

See also

Tutorial Project
Provides an example of creating a project and managing files in Workspace.

Edit

The Edit screen becomes available when you open a project. When you open a workflow from Workspace, pSeven switches to Edit automatically. Note also that if you open a project you have earlier worked on, pSeven remembers which workflows were open in the previous session, and automatically reopens them in Edit when you load the project.

_images/page_introduction_04_edit.png

The Edit screen contains:

  • The Block Library pane 1 — pSeven component library.
  • The tab bar 2. You can open and edit multiple workflows, switching between their tabs. You can also add, open and save workflows using the buttons in the tab bar.
  • The edit toolbar 3.
  • The view toolbar 4.
  • The information panel 5.
  • Workflow breadcrumbs 6. The context button in breadcrumbs opens Workflow Tree 7 (structural overview).
  • The main edit area 8 showing workflow structure — blocks and links.

Blocks are added to the workflow from the Block Library pane. To place a block, drag and drop it into the edit area or double-click its name in Block Library.

To configure a block, select it in the workflow and click b_config on the edit toolbar, or just double-click the block to open its configuration dialog. To connect blocks, drag a link from source to target or select Links from the context menu b_context on the edit toolbar.

When you have a block or link selected, the information panel shows useful details such as a summary of the block’s configuration.

The view toolbar can be used to zoom and pan the workflow, toggle annotations and automatically layout blocks and links.

The breadcrumbs and Workflow Tree help to navigate complex workflows with hierarchical structure (see further).

Lastly, the togglable Issues pane in Edit shows workflow validation messages. pSeven automatically validates the workflow while you edit and can warn you about block misconfiguration, missing links, and other potential problems.

See also

Simple Workflow tutorial
Provides a basic example of workflow editing and block configuration.

Workflow Structure

The main area in Edit shows base workflow structure.

_images/page_introduction_05_wfstruct.png

Main elements of a workflow are blocks 1 and links 2. Blocks have named inputs and outputs called ports; links create port connections. Hovering a block or link shows a tooltip 3 with port details. Double-clicking blocks and links opens their properties.

Optionally, a workflow can also contain text annotations 4. Clicking b_ann on the edit toolbar adds a new empty annotation; double-clicking an annotation begins editing text.To finish editing, click anywhere outside the text box.

There is one special block type in pSeven, Composite, which may be understood as a “sub-workflow” container.

_images/page_introduction_06_cb.png

You can view its contents by clicking the icon “View nested blocks” 1 which appears when you hover a block. To return to the above level, use workflow breadcrumbs 2 or the workflow tree.

Composite blocks provide several advanced functions — in particular, they allow to define parallel and cached workflow regions and to create your own custom components (for more details, see section Workflow).

Another important part of a workflow is the workflow configuration, which is opened by clicking b_runconf on the edit toolbar. First of all, you can use it to set up port monitoring — the main method to collect data from a workflow for analysis. Workflow configuration also allows to customize the workflow’s interface in Run and to add some advanced settings, such as global parameters.

See also

Simple Workflow tutorial, section Monitoring
pSeven monitoring mechanism in more detail.
Workflow as a Tool
Provides an example of using workflow configuration.

Run

Likewise Edit, the Run screen becomes available when you open a project. In Run you can specify workflow inputs and parameter values, adjust monitoring settings, start (and stop) workflows, read run logs, and see some results.

_images/page_introduction_07_run.png

The Run screen contains:

  • The tab bar 1 showing all open workflows.
  • The run toolbar 2.
  • The view toolbar 3 (the same as in Edit).
  • Workflow structure overview 4.
  • The Inputs pane 5.
  • The Outputs pane 6.
  • The Parameter settings pane 7.
  • The Monitoring settings pane 8.
  • The Run Log tab 9.
  • The Statistics pane 10.

Note that you cannot edit a workflow in Run: the overview allows only to navigate the workflow and review the structure. However, you can make changes in the workflow configuration b_runconf, opening it from the run toolbar.

The Inputs pane shows top-level workflow inputs, if they were added in the workflow configuration. You can specify input values here (double-click to edit).

The Outputs pane, similarly, shows top-level workflow outputs, if any. Output values are shown here after you run the workflow; this is useful for simple results, while a full-featured data analysis is available in Analyze.

The Statistics pane displays information about the progress of workflow runs (finished successfully or with errors), execution time and block statistics.

When you start a workflow, the bottom pane automatically switches to the Run Log tab. The log contains various diagnostic messages. If the workflow contains blocks that print to screen, their screen output is also redirected to the run log — in particular, it allows to print workflow results to the log if you prefer. Note that the run log is not a copy of the pSeven console log: each workflow tab contains its own run log which shows only workflow messages, and the console shows all application messages.

While a workflow runs, pSeven captures all data appearing on the monitored ports and stores it to the project database. This data does not show up in Run but can be post-processed in Analyze. Note that the project database is updated in real time, so you can start a workflow and immediately switch to Analyze to begin working with partial results. In particular, this allows to create live tables and plots which update automatically while a workflow runs.

Lastly, the togglable Issues pane in Run shows warnings related to run settings — such as incorrect parameters, missing inputs, and other potential problems.

See also

Workflow as a Tool
Provides an example of a simple workflow with a customized Run interface.

Analyze

The Analyze screen is used to post-process workflow results obtained from monitoring which are stored to the project database. This screen also becomes available only after you open a project.

_images/page_introduction_08_analyze.png

The Analyze screen contains:

  • The Project Database pane 1 which shows all monitored data.
  • The tab bar 2 showing all open reports. Also contains buttons to open, save, and add new reports.
  • The report toolbar 3 with various analysis and plotting tools.
  • Report windows 4 (tables, plots, and such).
  • The main editing area 5.

In Analyze you create reports, selecting data from the project database and then processing it with the tools available from the report toolbar. Each tool creates another window in the report — a table, a plot of specific type, and so on.

To begin editing a report, you can select some database records in the Project Database pane and drag them to the editing area. pSeven creates a copy of this data in the report (keeping it linked to the project database, see below) and automatically formats it to a table. You can then use the new table as a data source: selecting some columns from the table and clicking a button on the report toolbar adds a new report window showing the data from the selected columns — for example, you can use this feature to quickly add various plots.

The togglable Issues pane in Analyze shows warnings related to report configuration — for example, missing data sources, mistakes in plot settings, and other potential problems.

Note that all workflows in a project share the same project database, though they write results to different locations. Every report, in turn, can access entire project database. This allows you to create reports that combine results from different workflows while keeping the source data organized.

See also

Simple Workflow tutorial, section Results
Provides a basic example of report editing.

Report Structure

A report is a bit more than a collection of tables and plots. Each report has its own data storage, the report database. It contains a number of 1D arrays called data series which are automatically formed from multidimensional project database records when you add data to the report.

_images/page_introduction_09_dspane.png

You can view the report database using the Data Series pane 1 toggled from the report toolbar 2.

Data series are created when you drag a project database record to the report. pSeven forms them automatically — for example, if the source record contains several matrices, they are stacked vertically and each column from the stack becomes a new data series.

Report windows actually source from these data series, they do not get data from the project database directly. It simplifies plot configuration and adds the following important properties to a report:

  • If you open a project with an existing report and run related workflows again (for example, with some changes in configuration), you can easily update the report with new data.
  • If the project database is corrupt or was deleted, it does not break reports in the project because they still have a copy of data. Only the refresh functions will stop working.

The report database works as an intermediate data layer. Data series remember their sources in the project database, so normally a report can be updated automatically at any time (it re-reads data from the project database, updates data series, then refreshes report windows). However, data series also always contain the most recent copy of data, so the report remains intact if the original data is deleted from the project database.

See also

Results and Reports tutorial, in particular section Report Database
Provides an example of working with a report database and advanced report configuration.

Conclusion

This introduction does not aim to explain every function in detail and provides only the most essential information. To get familiar with pSeven, it is recommended to complete the introductory tutorials referenced above, namely:

These tutorials use simple examples to explain common pSeven functions. Note that other tutorials do not explain such functions in detail but focus on solving specific tasks — for example, training an approximation model, optimization, or integrating an external program into a workflow. Completing the introductory tutorials will also make it easier for you to study the examples installed with pSeven, adapt them to your needs, and create new projects.

See also

Tutorials
All pSeven tutorials.